How to check PHP loaders ability of the server?

Our product can now be run only on IonCube loader.
ZendGuard Loader (previously called as ZendOptimizer) is not supported since version 5.8.1.12 (August 05, 2019)
 
Since version 5.10.0.2 (March 25, 2021) we support only PHP 7.2. and newer.
 
Previous versions:
We recommend to use IonCube Loader with Post Affiliate Pro / Post Affiliate Network. Zip file "_ionEncoded54.zip" works for PHP versions from 5.4 to 5.5.
If you are running PHP 5.6 use the "_ionEncoded70.zip" file which works for both versions PHP 5.6 and PHP 7.0.
For PHP 7.1 and higher use the "_ionEncoded71.zip".
 
Important note: Always use binary mode when uploading files to your server using FTP.
 
IonCube loader
Here you can download latest version for your server (feel free to use their installation wizzard for smoother installation):
With this type of encoder use product archive ending with "_ionEncoded54.zip" for PHP 5.4.x, 5.5.x . And for PHP 5.6.x or PHP 7.0 you need to use "_ionEncoded70.zip" (this file is working for PHP 5.6.x and PHP 7.0.x). For PHP 7.1 you need to use "_ionEncoded71.zip". For PHP 7.2 you need to use "_ionEncoded72.zip"(this file works for PHP PHP 7.2.x, PHP 7.3.x and PHP 7.4.x)
 
Test script
You can use this script to check what encoders you have installed on your server. Just Create new file test.php on your server and paste this code in it:
 
<?php
echo "PHP version: <b>" . PHP_VERSION . "</b><br><br>";

if (PHP_MAJOR_VERSION == 4) {
    die('Not supported PHP version');
}

if (is_int(PHP_MAJOR_VERSION) && PHP_MAJOR_VERSION <= 5) {
    die('PHP 5.x.x is Not supported anymore, due to security issues.');
}

if (is_int(PHP_MAJOR_VERSION) && PHP_MAJOR_VERSION == 7 && PHP_MINOR_VERSION <= 1 ) {
    die('PHP 7.0.X, 7.1.X versions are not supported anymore, due to security issues.');
}

$extensions = get_loaded_extensions();
echo "<i>Supported loaders:</i><br><br>";
if (in_array('ionCube Loader', $extensions)) {
    $isCorrectVersion = true;
    $ioncubeVersion = '';
    if (function_exists('ioncube_loader_version')) {
        $ioncubeVersion = ioncube_loader_version();
        $ioncubeMajorVersion = (int) substr($ioncubeVersion, 0, strpos($ioncubeVersion, '.'));
        $ioncubeMinorVersion = (int) substr($ioncubeVersion, strpos($ioncubeVersion, '.') + 1);
        if ($ioncubeMajorVersion < 6) {
            $isCorrectVersion = false;
            echo 'ionCube Loader ' . $ioncubeVersion . ' - old, required is a minimum of ionCube Loader version 6.0<br>';
        }
    }
    if ($isCorrectVersion) {
        if (!is_int(PHP_MAJOR_VERSION) || !is_int(PHP_MINOR_VERSION)) {
            die('Error: unable to decode php version');
        }
        if ((PHP_MAJOR_VERSION == 7 && PHP_MINOR_VERSION >= 2)) {
            echo "<b>ionCube Loader</b>" . ($ioncubeVersion != '' ? " (v$ioncubeVersion)" : '') . " - use product (ZIP file) ending with '<b>_ionEncoded72.zip</b>' (PHP 7.2.x, PHP 7.3.x or PHP 7.4.x)<br>";
        } else {
            echo "<b>ionCube Loader</b>" . ($ioncubeVersion != '' ? " (v$ioncubeVersion)" : '') . " - '<b>Not supported PHP version</b>' (All PHP 5.X.X, 7.0.X, 7.1.X versions)<br>";
        }
    }
}

//version 4

//Note: Always use binary mode when uploading files to your server using FTP

//PLEASE DELETE THIS SCRIPT AFTER INSTALLATION!
?>
 
This script will print out supported loaders. For more info check your phpinfo. Create script info.php and paste this code in it:
 
<?php
phpinfo();
?>
 
Try to find some traces about ZendGuardLoader or IonCube loader there...